このディレクトリの索引
http://toro.2ch.net/test/read.cgi/tech/1364700745/818
#  すみませんもう1問お願いします; 
#   
#  [1] 授業単元:プログラミング演習 
#  [2] 問題文(含コード&リンク): 
#  for文の二重ループを用いて、下の実行結果のように0〜9までの数字を 
#    0から1個ずつ増やしながら10行表示するプログラムを作成せよ 
#     
#    0 
#    01 
#    012 
#    0123 
#    01234 
#    012345 
#    0123456 
#    01234567 
#    012345678 
#    0123456789 
#   
#  

'for文の二重ループを用いて、下の実行結果のように0〜9までの数字を0から1個ずつ増やしながら10行表示する'(N) :-
        for(0,M,9),
        for(0,N,M),
        write('%t',[N]),
        N = M,
        write('\n'),
        M = 9.        

for(S,N,E) :-
        E < S,
        for_1(S,N,E).

for_1(S,_,E) :-
        S < E,!,fail.
for_1(S,N,E) :-
        N is S.
for_1(S,N,E) :-
        S1 is S - 1,
        for_1(S1,N,E).

for_2(S,_,E) :-
        S > E,!,fail.
for_2(S,N,E) :-
        N is S.
for_2(S,N,E) :-
        S1 is S + 1,
        for_2(S1,N,E).